@kyanny's blog

My life. Opinions are my own.

emerge --sync ができなくなってしまった

emerge --sync (eix-sync) が昨日の夜からできなくなってしまいました。ミラーをかえてみてもダメ。エラーメッセージをみると、 rsync のプロトコルバージョンが違うのが原因のような気がしました。 ~x86 で 3.0.0-pre なんとかいうのが入っていたので、 package.mask に >net-misc/rsync-2.6.9-r5 とか書いてダウングレードし、またやってみたら今度は socket error か何か。たぶん何度も sync しすぎて一時的にバンでもされたんでしょう。。 kde 系の 3.5.9 がちょっと前にきてたから amarok に再挑戦したかったのだけど。残念。