@kyanny's blog

My life. Opinions are my own.

gettext と gettext/rails のバージョンによる違い

メモ。

Ruby の gettext パッケージは、 1.x 系と 2.x 系で gettext/rails っていうファイルの有無に差があるっぽい。 rails 2.0 とかだと gettext 1.90.0 とかの gettext/rails を同梱してるバージョンじゃないとダメのようで gettext/rails がないよー、というエラーがでる。 gettext 2.x からは gettext/rails がなくなって gettext_rails という別の gem になったようだ。

古い gettext を入れたい場合は、

$ sudo gem install gettext -v=1.90.0

で ok.