@kyanny's blog

My life. Opinions are my own.

last.fm の日本語 UI からログインできない問題が解決したと連絡があったがまだ解決していなかった

ちょっと前にサポート宛にログインできません!とメールを送った返信がきていて、いまはもう直ったはずだけどまだダメだったら OS のバージョンとかも教えてくれ、というので試してみたらまだダメだったので、 OS のバージョンと HTTP リクエスト/レスポンスヘッダをコピペして送りました。

OS のバージョンと聞かれて、「そういえば Gentoo Linux には他のディストリビューションみたいな明確なバージョンがないから、どう答えたものだろう」とちょっと困ってしまいました。前にどこかで、「特定のファイルのタイムスタンプを調べればいつインストールされたか推測できるから、そこからバージョンっぽいものを決めることはできるけど、 Sarge だ Etch だ、みたいな風には決められないね」というのを読んだことがありました。結局 Gentoo Linux (Gentoo 2007.0) とかいておいた。

あと LiveHTTPHeaders でヘッダをみていたら、 last.fm 本家のほうは nginx ってウェブサーバを使っているようでした。日本のほうは apache の 1.3.39 だった。